解决composer提示版本太旧You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade.

2020-10-31   阅读:805   分类:后端    标签: composer

Warning from https://mirrors.aliyun.com/composer: You are using an outdated version of Composer. Composer 2.0 is now available and you should upgrade. See https://getcomposer.org/2

Updating dependencies (including require-dev)

PHP Fatal error:  Allowed memory size of 1610612736 bytes exhausted (tried to allocate 4096 bytes) in phar://D:/ProgramFiles/composer/composer.phar/src/Composer/DependencyResolver/Solver.php on line 223

image.png

最近用laravel发现,在安装扩展是一直报composer版本错误。

原因:从报错信息可以看出是composer版本太旧的。

解决办法:升级本地的composer版本

composer self-update


image.png

【腾讯云】11.11 云上盛惠,云产品限时抢购,1核2G云服务器首年88元

‘简忆博客’微信公众号 扫码关注‘简忆博客’微信公众号,获取最新文章动态
转载:请说明文章出处“来源简忆博客”。http://www.tpxhm.com/adetail/493.html

×
觉得文章有用就打赏一下文章作者
微信扫一扫打赏 微信扫一扫打赏
支付宝扫一扫打赏 支付宝扫一扫打赏

文章评论(0)

登录
简忆博客壁纸 头像

简忆博客
仕而优则学,学而优则仕。

置顶推荐

打赏本站

如果你觉得本站很棒,可以通过扫码支付打赏哦!
微信扫码:你说多少就多少~
微信扫码
支付宝扫码:你说多少就多少~
支付宝扫码
×