关于Mac系统下wepy运行环境和vue运行环境冲突Error: Vue packages version mismatch:问题的解决方法

2023-06-08   阅读:634   分类:前端    标签: wepy

安装好wepy环境好了之后,运行wepy热更新打包wepy build --watch,出现下面错误信息:

/usr/local/lib/node_modules/@wepy/cli/node_modules/vue-template-compiler/index.js:10

throw new Error(

^

Error:

Vue packages version mismatch:

- vue@3.3.4 (/usr/local/lib/node_modules/vue/index.js)

- vue-template-compiler@2.7.14 (/usr/local/lib/node_modules/@wepy/cli/node_modules/vue-template-compiler/package.json)

This may cause things to work incorrectly. Make sure to use the same version for both.

If you are using vue-loader@>=10.0, simply update vue-template-compiler.

If you are using vue-loader@<10.0 or vueify, re-installing vue-loader/vueify should bump vue-template-compiler to the latest.

at Object.<anonymous> (/usr/local/lib/node_modules/@wepy/cli/node_modules/vue-template-compiler/index.js:10:9)

当从字面上翻译,是vue和vue-template-compiler版本不一致,导致的,实际上是环境问题。接下来,我们就来处理这个问题。

1、首先先把关于vue的文件夹都移除或者删除,想恢复的可以备份

这里博主把位于/usr/local/lib/node_modules目录下的@vue和vue文件夹都删除放进回收站里面,以及/usr/local/bin目录下的vue快捷指令都删除。

2、接下来重新安装vue脚手架环境,安装指定版本,@vue/cli 4.5.13

sudo npm install -g @vue/cli@4.5.13

这样成功解决环境冲突问题。

【腾讯云】年度爆款2核2G4M云服务器118元/年,新老用户同享

‘简忆博客’微信公众号 扫码关注‘简忆博客’微信公众号,获取最新文章动态
转载:请说明文章出处“来源简忆博客”。http://www.tpxhm.com/fdetail/976.html

×
觉得文章有用就打赏一下文章作者
微信扫一扫打赏 微信扫一扫打赏
支付宝扫一扫打赏 支付宝扫一扫打赏

文章评论(0)

登录
简忆博客壁纸一
简忆博客壁纸二
简忆博客壁纸三
简忆博客壁纸四
简忆博客壁纸五
简忆博客壁纸六
简忆博客壁纸七
简忆博客壁纸八
头像

简忆博客
勤于学习,乐于分享

置顶推荐

打赏本站

如果你觉得本站很棒,可以通过扫码支付打赏哦!
微信扫码:你说多少就多少~
微信扫码
支付宝扫码:你说多少就多少~
支付宝扫码
×