centos7修改默认php版本

2020-08-15   阅读:307   分类:后端    标签: 服务器

centos7安装swoole报PHP版本问题。

PHP Warning:  pclose() expects parameter 1 to be resource, null given in /usr/local/php/lib/php/OS/Guess.php on line 251

pecl/swoole requires PHP (version >= 7.1.0), installed version is 5.6.40

image.png

1、删除之前系统默认的

rm -f /usr/bin/php

2、创建7.4版本的软连接

ln -sf /usr/local/php7.4/bin/php /usr/bin/php

输入php -v,可以看到当前版本:

image.png

【腾讯云】11.11 云上盛惠,云产品限时抢购,1核2G云服务器首年88元

‘简忆博客’微信公众号 扫码关注‘简忆博客’微信公众号,获取最新文章动态
转载:请说明文章出处“来源简忆博客”。http://www.tpxhm.com/adetail/381.html

×
觉得文章有用就打赏一下文章作者
微信扫一扫打赏 微信扫一扫打赏
支付宝扫一扫打赏 支付宝扫一扫打赏

文章评论(0)

登录
简忆博客壁纸 头像

简忆博客
仕而优则学,学而优则仕。

置顶推荐

打赏本站

如果你觉得本站很棒,可以通过扫码支付打赏哦!
微信扫码:你说多少就多少~
微信扫码
支付宝扫码:你说多少就多少~
支付宝扫码
×